Can you open Mobee app today?

My Mobee app does not display any missions today. When I tried to search for shops, the app says “something went wrong, please try again”.
I saw tons of new missions available early this morning around 7 am. Then it shows no shops at all. My achievements were not being displayed either. I get the same message on my achievements page. Is it just me? Or do you also have the same problem today?

Create an Account or Log In

Membership is free. Simply choose your username, type in your email address, and choose a password. You immediately get full access to the forum.

Already a member? Log In.

If you are still having this issue, UNINSTALL the Mobee app from your phone. Then go back into the app store and re-install it. You'll need to enter your already-established username and password.
Mobee Support replied to a query I sent about Achievements not posting correctly; they said it's a known issue and the programmers are working on a fix.
Hope this helps!

Greetings from southeastern Wisconsin on the Illinois stateline
Thank you for replying! The problem was solved. They accidentally deactivated my account.
Sorry, only registered users may post in this forum.

Click here to login