Gigspot Technical Issues, save your narratives . . .

Hi all,
I've been using Gigspot with a couple companies and until now it has worked out ok. Last night I did a shop at a well-known retail store and after a really awesome experience, I wrote up a great report giving lots of kudos to the staff. Gigspot app deleted the report when I hit the "Check Complete" button! It saved RANDOM answers like the uploaded receipt, and a yes/no button here and there. I was upset, obviously, but I tried it again. Same thing happened! I gave up and tried to access the report on my laptop using a browser and while it didn't delete the report (thankfully), it wouldn't let me submit it, either. This morning, to my relief, the green "Submit" button popped up. Finally! I'm sharing my experience so that if you are using Gigspot in the near future, and have narratives, it may be worth your while to copy and paste your crafted paragraphs into another doc in case this happens to you. The third and final report the company received is a sadly a skeleton of the original work. 2 hours in for a $25 shop after the time invested in traveling there and shopping was not what I bargained for. I sent the MSP an email to let them know what happened, not that it gives me my time back at this point.

Maybe they were updating a server late last night, who knows. But be mindful, whether you are using Gigspot's phone app or browser URL, and good luck smiling smiley

Create an Account or Log In

Membership is free. Simply choose your username, type in your email address, and choose a password. You immediately get full access to the forum.

Already a member? Log In.

I was just going to ask if anyone else found the website to be glitchy. It doesn't matter which device I'm on or if I'm using a hotspot or wifi network, it takes so long to load a page. I did the "check complete" too and it just took me back to the home screen. I thought, for sure, all my narrative had been lost, but luckily, it was 25 or so questionnaire anyway. Then, when I tried to upload my receipt, it took so long that I just refreshed the page.Fortunately, none of the glitches resulted in lost information, but I did get an error message saying that something went wrong just before I was going to hit "submit."
Hate the Gigspot platform. I had to take a certification test, and it took me forever. I kept getting error messages that I hadn't completed it, but no flags as to what wasn't complete, the app deleted responses when I tried to submit the certification, etc. I was ready to abandon the shop before even getting approved for it! I submitted the shop, and had similar issues. Responses were accepted, then flagged as not complete and not redlined where I needed to make corrections. Bah.

I learn something new every day, but not everyday!
I've learned to never trust spell-check or my phone's auto-fill feature.
I think it's a good concept, simple web design, but needs some tinkering on the executing. Maybe they used the same IT firm that designed and managed the site when it first went live
Sorry, only registered users may post in this forum.

Click here to login