Marketforce Helpdesk/Contact

Does anyone know how I can contact Marketforce besides their generic helpdesk e-mail? I completed an audit the other day and there is a glitch on their site when entering. Essentially I can enter the first 2 page of issues but not the 3rd. So, I can't complete the report. I have already e-mailed them twice. The audit is currently 3 days late. I'm not sure what else to do at this point. Any advice on who to contact? Thanks!!

Create an Account or Log In

Membership is free. Simply choose your username, type in your email address, and choose a password. You immediately get full access to the forum.

Already a member? Log In.

Your report won’t be dropped, since you already began entering the report. Since the glitch sounds legitimate and you sent them a heads up through their Helpdesk, you did your end of the gig. You shouldn’t and likely won’t be penalized for it being late on it, if this ‘glitch’ is on their end in the first place. Your email is in queue and you just have to wait on your end for their response. Of course, this is just my view and speculation on the situation based on my experiences with Market Force.

Shopping the Greater Denver Area, Colorado Springs and in-between in Colorado. 28 year old male and willing to travel! Badged for Denver International Airport.
OK - thanks! I guess I just need to be patient!

The manager didn't even want to do the audit. They called their manager and then the MF contact but no one answered after multiple calls. So, they gave in and I had to do the audit.
I ran into a problem with Market Force's app & website today too. I've now sent 3 emails to their help desk due to problems with 3 different shops. For the first shop, the app froze when I finished the report but I wasn't able to upload pictures or sign the CPI. I kept getting an error message that said to try again later. I tried later but then realized it was in QC, even though I didn't submit it.

For the next shop, I decided to wait until I got home to enter it. I was able to complete the report but then the website wouldn't load to go back and allow me to sign the CPI and review. I waited then clicked "save and exit", which did nothing. I then clicked home on their website and nothing happened. Now that shop is showing it's in QC, even though it's not complete.

For the 3rd shop, it was a web lead that I had to wait for a phone call. Yesterday, I submitted the web lead and entered the report up to the point of waiting for the phone call. After I received the phone call today, I went back in to finish the report and it's just gone. It's not in my shops to report log or completed shops log. It's just gone.... poof!

Anyone else having issues with Market Force's app or website?
I am having issues with the website. I can access my shops, but the home page will not load and the find shops page will not load either. I have several shops today that I plan on entering into the App; wish me luck.

Marketforce will work with you if you cover all your bases and explain what happened. For all above, if you have not, I encourage you to send an email to the help desk explaining exactly what you described above in your posts. I imagine they are probably getting a ton of emails right now it because of technical issues, so I eould not expect a quick reply.

Edited 1 time(s). Last edit at 02/18/2018 03:08PM by thunderdeacon.
@jentheshopper wrote:

I ran into a problem with Market Force's app & website today too. I've now sent 3 emails to their help desk due to problems with 3 different shops. For the first shop, the app froze when I finished the report but I wasn't able to upload pictures or sign the CPI. I kept getting an error message that said to try again later. I tried later but then realized it was in QC, even though I didn't submit it.

Yes. Mine is now in QC as well even though I didn't finish uploading the items due to the glitch, who knows if there were questions after that, and I definitely didn't sign the CPI either.
As of 3:30 CST I am still able to access, report, and reschedule MF shops without issue, but I still cannot get my home tab or the Find Shops tab to load
Just to follow up - the helpdesk couldn't figure it out either, so they just made a note to the editor. So, I never actually finished the report but just saw that it was approved! haha nice!
I was having the same issue and when they finally answered my emails about the issue, I was told that I had been terminated and would no longer be offered any shops from them. No explanation as to why or what I did to cause it.
It has been reported by MF that the Wireless Audits have a glitch. This does not allow you to sign your CPI and ROA slip.
Did you try using each of the three major browsers - Chrome, IE, and Firefox? I've had problems using Chrome with their new site.
Sorry, only registered users may post in this forum.

Click here to login