Trouble Getting Onto MarketForce Web Site

For the past 2 weeks, I have been unable to click on "Find Shops" & actually view shops. It just keeps loading. Tonight I'm trying to do a report & I can't get to step 2 "Review". It keeps going back to the 1st question (even though I did the report on the public library computer.) I can't review. I can't submit. I can't do anything. I've been trying on my laptop & phone. I'm using Chrome. Anyone else having this issue? Any help/suggestions? Thanks.

Create an Account or Log In

Membership is free. Simply choose your username, type in your email address, and choose a password. You immediately get full access to the forum.

Already a member? Log In.

Try Firefox.

Early today, I got that "loading" thing for hours....worried a bit that I might have been deactivated.

Rebooted, logged back in, and all is good.
For the past year or two I've used the app on my phone almost exclusively because the website would not load up on my desktop, the screen remained blank for hours, even rebooting the computer, and changing browsers didn't help. But I had to verify my payments to another entity earlier this year, so I opened up the website and went into the kitchen to cook. I came back 20 minutes or so later and the website was loaded and it let me sign in just like it's supposed to. I found my payment information, searched for some new jobs, and then signed out. It has worked for me almost immediately every time I've tried to open it since then. And I seriously don't know what changed or why.
Sorry, only registered users may post in this forum.

Click here to login