Maritz and major reporting issues anyone?

I completed a gas station inspection today and when I tried to enter the report it said my gas purchase was missing. Ok, so I know I filled in the amount of gas I got and the amount of the store purchase but I went ahead and filled them in again. Next thing the gas purchase is there but no store purchase. Again I fill in the store purchase and now the gas purchase is missing!!!! Finally played ping pong long enough for both to take at one time and I get an entirely different message about validation which lists 16 questions that were originally under each of the pumps as one long list (no pump numbers mentioned). Frustrated beyond means I called Maritz. Yes they have been having problems. Anyone else experience this? I' at the point of giving up 3 more I have scheduled and the other one I did today just to ease the frustration. Ideas?

Edited 1 time(s). Last edit at 02/12/2019 10:53PM by lbtweety47.

Create an Account or Log In

Membership is free. Simply choose your username, type in your email address, and choose a password. You immediately get full access to the forum.

Already a member? Log In.

I thought it was me. Yes, issues with having to resubmit random things that got dropped somehow. 19 shops this weekend. Oy.
It isn't you. I tried to enter the second report and got halfway through and hit "save". You guessed it, when I went back in all my answers were missing and only the pictures remained!
As far as I'm concerned, this has been an ongoing issue.
Upon submitting the debrief, I've had problems where it asks me why I've only reported on 11 pumps when I've listed 12. When I went go to look, I see the first pump is pump 2, pump 1 is missing!
Other times, there was no request for a diesel audit. But, after submitting the debrief, I find the shop was put on "hold" because I didn't submit the diesel portion.
Sometimes, when just about finished adding all the information (answering the questions and adding the photos), the complete report closes. When I go back to resubmit, only the photos are there and I have to put all the written information.
I just sigh and struggle through.
To me it is not worth the frustration. Yesterday I completed two shops and could not enter either of them. Between the time, driving, evaluation, downloading and re-naming photos, playing ping pong for hours with answers disappearing on the very poorly designed debrief, calling Maritz, and emailing their IT dept, I found myself making less than $1 per hour. If I do not hear back this morning from someone I will sever my relationship and have them remove all remaining jobs assigned.
@French Farmer wrote:

Sometimes, when just about finished adding all the information (answering the questions and adding the photos), the complete report closes. When I go back to resubmit, only the photos are there and I have to put all the written information.
I just sigh and struggle through.


THIS!!!!
This happens to me way too often. It's the reason I started using the app, but sometimes that takes forever to load.

Servimer Regional Manager- Nevada, Illinois, Wisconsin & Minnesota
Having major problems with the app today. Froze up three times and when I tried to go back in, all sections were not available. Anyone having problems with using the app offline? My problems were when I connected live with my LTE.
Here is a strange one: A shop I did recently was put on hold.
"Hold" issue for Visit #: please upload a photo of pump ###. Photo must be blah, blah blah.
So, I look at my pump photos for that visit address. I don't see a problem with that photo. Did I upload a wrong photo? I open up the Visit ID on hold and go to the pump number in question.
There is a photo of a man's head, clearly taken in a warm climate (the temperature the day of the photo was +5F. I have never seen this man and could not find it anywhere in my photo files.
Once again, I sigh, correct the "Hold" and move on.
Sorry, only registered users may post in this forum.

Click here to login